MemoryMixer Software System Requirements


Windows
MemoryMixer needs Java and QuickTime to run. These are common applications that many computer programs use and most computers already have. Use these quick links to make sure you have them installed: JAVA (install JAVA 1st) and then QuickTime
     • Windows XP, Vista, Win 7, Win 8 or Win 10      • Pentium 4, 1 GHz or better (1.6 GHz recommended)      • 1 GM RAM available (2 GB or more recommended)      • 16 MG Video RaAM (64 MB recommended)      • Install requires 3GB available Hard Disk Space

Mac
     • OS X 10.4.x or greater (with latest Java update) through Snow Leopard & Mavericks. MemoryMixer is not currently compatible with Yosemite 10.10, El Capitan 10.11, or Sierra 10.12. A Beta is available for os 10.11, 10.12. If you would like to be part of our testing, please contact the office during business hours.      • G4 500 MHz or Faster (G5 1 GHz or better recommended)      • 1GB RAM available (2 GB or more recommended)      • 1 GB RAM available (2 GB or more recommended)      • 8 MB Video RAM (64 MB recommended)      • Install requires 3GB available Hard Disk Space

Password: